2010年 6月 19

使っているPHPのプログラムで Notice: Undefined variable: というエラーログが残るのがウザすなので対策。

php.ini の error_reporting = E_ALL & ~E_NOTICE がコメントアウトされているので有効化する。

;error_reporting = E_ALL & ~E_NOTICE
↓有効化
error_reporting = E_ALL & ~E_NOTICE

error_reporting  =  E_ALL
↓ コメントアウト
;error_reporting  =  E_ALL

Apache を再起動して設定を有効にする。

More from my site

  • centOS4.8 apache2.0.x を apache 2.2.15 へ yum でアップデートcentOS4.8 apache2.0.x を apache 2.2.15 へ yum でアップデート utterramblings レポジトリを使い apache を2.2.15 へ yum でアップデートする。 phpも5.2.13 へアップデートされる。 remiレポジトリでもいいけど PHPが5.3になってしまうので。 utterramblingsレポジトリ追加 # rpm --import […]
  • centos4.8のphp4.xをyumでphp5.1.6にアップデートcentos4.8のphp4.xをyumでphp5.1.6にアップデート ケース1 すでにyumでphp4がインストール済みのcentos4.8にphp5.1.6をインストールする方法です。 *centosplusリポジトリの追加は行ってある前提です。 # yum --enablerepo=centosplus update php としてもエラーで進まない。 Transaction Check Error: file […]
  • CentOS4.8 に Zend Framework をインストールCentOS4.8 に Zend Framework をインストール 環境 CentOS 4.8 Apache 2.2.15 PHP 5.2.13 Zend Framework ダウンロード http://framework.zend.com/download/latest 「Zend Framework Full Package」から Zend Framework 1.10 full […]
  • CentOS 5.5 php5.3.6からphp5.2.17へyumでダウングレードCentOS 5.5 php5.3.6からphp5.2.17へyumでダウングレード remiリポジトリでphp5.3をyumでインストールしたけど、php5.2で動いていたスクリプトが動かない。 困るのでphpをダウングレードする。 php関連パッケージを調べる。 # yum list installed | grep php* php.i386 5.3.6-1.el5.remi […]
  • CentOS5.5にZend OptimizerをインストールCentOS5.5にZend Optimizerをインストール Live Commerceを使うのにはZend Optimizerが必要なのでインストールする。 CentOS5.5(32bit) PHP 5.2.16 ダウンロード ダウンロード場所がわかりにくいので注意 ※Zend OptimizerをダウンロードするにはMyZendに登録する必要がある。 ゼンド・ジャパン株式会社 ダウンロード>Zend […]
  • PhpMyAdminの導入PhpMyAdminの導入 phpmyadminインストール yum install phpmyadmin /usr/share/phpmyadmin にインストールされる。 /usr/share/phpmyadmin/config.inc.phpを編集 $cfg['blowfish_secret']を設定。 /* * This is needed for cookie based […]

Filed under: PHP

Trackback Uri



コメントする